پایان عمر PHP5.5 و پشتیبانی کلودلینوکس از آن
صفحه اصلی » PHP, اخبار, اخبار روز دنیای فناوری اطلاعات, اخبار لایسنس ها > پایان عمر PHP5.5 و پشتیبانی کلودلینوکس از آن

پایان عمر PHP5.5 برای شما و مشتریان شما چه معنی دارد؟

پایان عمر PHP5.5 در کلود لینوکس

نسخه PHP5

 

اکثر نسخه های محبوب php که توسط کاربران استفاده می شود، دیگر توسط php.net پشتیبانی نمی شوند و از تاریخ 21 ژوئن امسال PhP5.5  نیز به جمع آنها اضافه شد. این نسخه های php دیگر توسط جامعه php پشتیبانی نخواهد شد. این بدان معنی می باشد که اگر مشکل امنیتی در php5.5  یا نسخه های قبلی آن کشف شود، دیگر در آپدیت های بعدی آن رفع نخواهد شد. این بر روی 84درصد کل سایت های PhP تاثیرگذار خواهد بود.

PhP.net محبوب ترین زبان برنامه نویسی طرف سرور با ظرفیت پذیرش و استفاده 82 درصدی در بین کاربران، در مقایسه با دیگر رقیبان خود از جمله ASP.Net با داشتن سهم 15 درصدی از بازار می باشد.

PHP5 diagrams

بر اساس تصاویر بالا PhP5 توسط 98.7 درصد وب سایت هایی که با php پیاده سازی شده اند، استفاده می شود. و 20 درصد از کل وب سایت هایی که از php5 استفاده می کنند، در حال استفاده از php5.5 می باشند. به دلیل این آمار بالای استفاده از php5 ، هکرها مکررا دنبال راه های هک و نفوذ به سایت هایی می باشند که از این نسخه ها استفاده می کنند.

در حالت عادی پشتیبانی PHP به چه صورت می باشد:

در حالت عادی به مدت دو سال تمام باگ ها و حفره های امنیتی گزارش شده رفع و نسخه های کامل و صحیح منتشر می شود. بعد از آن دو سال، یک سال اضافه هر نسخه از php برای مسائل امنیتی حیاتی همچنان پشتیبانی می شود. پس از رسیدن به نقطه پایان این سه سال ، آن نسخه دیگر توسط جامعه PHP.Net پشتیبانی نخواهد شد.

در حال حاضر نسخه های 5.0 تا 5.5 دیگر توسط جامعه php پشتیبانی نمی شوند، پس عملا 86درصد از سایت های PHP5 دیگر پشتیبانی نمی شوند.

چطور سایت های PHP5  کاربران را امن نگه داریم:

عموما نسخه هایی که پشتیبانی نمی شوند، لازم است هر چه سریع تر به نسخه های بالاتر آپدیت شوند، اما طبق معمول زمانی که یک نسخه از php منسوخ می شود، انتقال به نسخه بالاتر برای صاحبان وب سایت ها همیشه کاری دشوار و زمان بر می باشد.

اما تا زمانی که شما از Hardened php که به همراه Cloudlinux ارائه می شود استفاده می کنید، سایت های شما و مشتریان شما ایمن خواهند بود و نیازی نیست مشتریان خود را مجبور کنید PHP خود را ارتقاء دهند و تنها کافی است اسکریپت های PHP قدیمی خود را بازنویسی کنند.

شما نیز به عنوان فراهم کننده خدمات میزبانی وب نیز لازم نیست php سرورهای خود را آپدیت کنید و باعث ایجاد مشکلات برای کاربران خود شوید.

ما به مشتریان خود قول می دهیم به انتشار پچ های امنیتی برای نسخه های قدیمی php در آینده ادامه دهیم و تا زمانی که سایت هایی از این نسخه ها استفاده می کنند، توسط ما پشتیبانی خواهند شد.

با استفاده از Hardened PHP در سیستم عامل CloudLinux شما می توانید نسخه های قدیمی PHP را ایمن نگه دارید و توسط PHP Selector می توانید پکیج های مختلف PHP را بر روی یک وب سرور اشتراکی به منظور به حداکثر رساندن امنیت قرار دهید.

نظرات




 

تمامی حقوق برای شرکت بین المللی نیک سپهر محفوظ است. طراحی سایت